PLM之家精品课程培训,联系电话:18301858168 QQ: 939801026

  • NX二次开培训

    NX二次开培训

    适合初级入门或想深入了解二次开发的工程师,本培训结合ufun,NXOpen C++,大量的实例及官方内部的开发技术对于老鸟也值得借鉴!.

    NX CAM二次开发培训报名 NX二次开发基础培训报名
  • PLM之家Catia CAA二次开发培训

    Catia二次开发培训

    Catia二次开发的市场大,这方面开发人才少,难度大。所以只要你掌握了开发,那么潜力巨大,随着时间的积累,你必将有所用武之地!

  • PLM之Teamcenter最佳学习方案

    Teamcenter培训

    用户应用基础培训,管理员基础培训,管理员高级培训,二次开发培训应有尽有,只要你感兴趣肯学习,专业多年经验大师级打造!

  • PLM之Tecnomatix制造领域培训

    Tecnomatix培训

    想了解制造领域数字化吗?想了解工厂,生产线设计吗?数字化双胞胎,工业4.0吗?我们的课程虚位以待!

PLM之家PLMHome-国产软件践行者

[资料分享] 二次开发编译器Visual Studio版本匹配常见问题和解决方案

[复制链接]

2023-6-11 13:53:09 1141 0

admin 发表于 2023-6-11 13:53:09 |阅读模式

admin 楼主

2023-6-11 13:53:09

请使用QQ关联注册PLM之家,学习更多关于内容,更多精彩原创视频供你学习!

您需要 登录 才可以下载或查看,没有账号?注册

x
二次开发编译器Visual Studio版本匹配常见问题和解决方案: e$ K: x- p- p% }

  s" n7 C0 h6 b; L; W+ B5 o- _1 X( N* i
1. 首先版本最好匹配,关于不同NX版本和不同IDE之间版本可以参考PLM之家其他帖子描述,不同系统也有说明7 i8 ]# _4 }: ]$ Y3 e
2. 从NX1847 过后,版本之间没有太大界限,但是会提示版本不匹配情况,可能出现意想不到的错误情况。建议使用匹配版本。
% y2 L8 G! z* H% ~2 m比如NX1953对应的是VS2019,平台工具集V142,如果非要用V143,VS2022版本,编译通过没问题,但是运行程序会得到以下警告。
1 p& Y8 g# J/ t/ Y2 R1 F3 ] QQ截图20230211135213.png
; J1 j- Q1 M4 v弹出消息窗口可以想办法设置关掉,但是不建议这么玩儿!!9 D4 |8 b. {. w  h
3. 一个比较高版本的IDE如何兼容低版本NX的IDE要求,最常见的方式如下,修改IDE
7 U. x' l' `  s0 \0 M, J
; Q/ |" N& Z* h0 M5 b% X7 [ aaa.png ! f$ s) L& L) K/ [' L- `
1.PNG
! ~- G1 l+ G; [* q& V9 E( t
上海点团信息科技有限公司,承接UG NX,CATIA,CREO,Solidworks 等CAx软件,Teamcenter,3D Experience等PLM软件,工业4.0数字化软件的实施\二次开发\培训相关业务,详情QQ 939801026 Tel 18301858168 网址 www.diantuankj.com/ doTeam.tech
回复

使用道具 举报

发表回复

您需要登录后才可以回帖 登录 | 注册

返回列表 本版积分规则

  • 发布新帖

  • 在线客服

  • 微信

  • 客户端

  • 返回顶部

  • x
    温馨提示

    本网站(plmhome.com)为PLM之家工业软件学习官网站

    展示的视频材料全部免费,需要高清和特殊技术支持请联系 QQ: 939801026

    PLM之家NX CAM二次开发专题模块培训报名开始啦

    我知道了